[Fix phpMyAdmin] Konfigurasjonen file trenger nå en hemmelig passord (blowfish_secret)

Enten det er installert phpMyAdmin serveren Ubuntu, CentOS eller etc. Fedora distribusjon, meldingen "Konfigurasjonen file trenger nå en hemmelig passord (blowfish_secret)”Med rødt nederst i indeksen, gir det hodepine. Spesielt når den er riktig konfigurert i "/etc/phpMyAdmin/config.inc.php".
Selvfølgelig kan banen variere fra en konfigurasjon til en annen, men på 7 CentOS cu phpMyAdmin installert via “yum"Fra"remi.repo", Konfigurasjonsfilen ligger i" / etc / phpMyAdmin / ".

Ok, la oss se hvordan vi løser det "Konfigurasjonen file trenger nå en hemmelig passord (blowfish_secret)", hvis i config.inc.php vi har denne linjen:

$cfg['blowfish_secret'] = 'gNsWq$%#%$#%EDFSsffsegbVp6LCJw6w'; /* YOU MUST FILL IN THIS FOR COOKIE AUTH! */

Hvis denne linjen er tilstede og vi har en "nøkkel" på mer enn 32 tegn, bør den røde meldingen i phpMyAdmin forsvinne.
Hvis dette ikke har skjedd, er det bra å slette informasjonskapsler i nettleseren din og logge av phpMyAdmin. Ved neste pålogging, meldingen "Konfigurasjonen file trenger nå en hemmelig passord (blowfish_secret)"Han vil ikke lenger være til stede.
Selv om det finnes situasjoner der det er til stede ikke på grunn av feilkonfigurasjoner config.inc.php filen, men på grunn av mappetillatelser da han var.

Kjør i terminal kommandolinjen:

 chown -R root:<user web> /etc/phpMyAdmin/

Nå skal alt være ok. Hvis du bruker Apache, i stedet for "nettbruker", angir du "httpd", "nginx" eller hvordan du har webprosessbrukeren på serveren.

Jeg skrev disse tipsene fordi jeg gikk gjennom hele phpMyAdmin-konfigurasjonen i mer enn 2 timer, og jeg kan fortsatt ikke bli kvitt meldingen: Konfigurasjonen file trenger nå en hemmelig passord (blowfish_secret). Etter at jeg løste tillatelsene / gruppene, forsvant den.

[Fix phpMyAdmin] Konfigurasjonen file trenger nå en hemmelig passord (blowfish_secret)

Om forfatteren

Stealth LP

Grunnlegger og redaktør Stealth SettingsI 2006 dato.
Erfaring med Linux-operativsystemer (spesielt CentOS), Mac OS X, Windows XP> Windows 10 og WordPress (CMS).

4 Kommentarer

Legg igjen et svar til Stealth X