Løs feil: PHP-installasjonen ser ut til å mangle MySQL-utvidelsen som kreves av WordPress

"PHP-installasjonen din ser ut til å mangle MySQL-utvidelsen som kreves av WordPress"Er en feil som mange blogg- og nettstedseiere har opplevd WordPress.
Dette er ikke grunn til bekymring. Mangel på MySQL-utvidelse fra PHP er typisk for operativsystemer installert fra bunnen av, VPS eller dedikerte servere, der PHP-utvidelser ikke var en del av installasjonspakken. Dette problemet er til stede på begge Ubuntu og CentOS. I dette scenariet løses problemet veldig enkelt med en PHP-oppdatering og modulinstallasjon "php-mysql".
Oppdater PHP og installer MySQL-utvidelsen på Ubuntu

apt-get update
apt-get install php-mysql

Oppdater PHP og installer MySQL-utvidelsen på CentOS

yum update
yum install php70w-mysql

Etter dette trinnet, start Apache-tjenesten på nytt eller Nginx.

Jeg møtte også på scenariet der selv om MySQL-utvidelsen eksisterer i PHP, viste en blogg opprettet på WordPress feilen "PHP-installasjonen din ser ut til å mangle MySQL-utvidelsen som kreves av WordPress". Det meste av tiden oppstår feilen når du installerer WordPress. Denne gangen dukket han imidlertid opp på en blogg som hadde vært aktiv i flere år.
I denne situasjonen fant jeg ut at problemet ikke er PHP-modulene, men den veldig gamle versjonen av WordPress, som ikke lenger er kompatibel med PHP 7.4.4RC1. En enkel WordPress-oppgradering til den nyeste versjonen løste feilen.

Løs feil: PHP-installasjonen ser ut til å mangle MySQL-utvidelsen som kreves av WordPress

Om forfatteren

Stealth

Lidenskapelig opptatt av alt som betyr gadget og IT, jeg skriver med glede på stealthsettings.com fra 2006 og jeg elsker å oppdage nye ting med deg om datamaskiner og macOS, Linux-operativsystemer, Windows, iOS og Android.

Legg igjen en kommentar